2075. Tangled in Cables

 

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

 

Input. Only one town will be given in an input.

·         The first line gives the length of cable on the spool as a real number.

·         The second line contains the number of houses, N

·         The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.

·         Next line: M, number of paths between houses

·         next M lines in the form

< house name A > < house name B > < distance >

Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

 

Output. The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need < X > miles of cable

Print X to the nearest tenth of a mile (0.1).

 

Sample Input

100.0

4

Jones

Smiths

Howards

Wangs

5

Jones Smiths 2.0

Jones Howards 4.2

Jones Wangs 6.7

Howards Wangs 4.0

Smiths Wangs 10.0

 

Sample Output

Need 10.2 miles of cable

 

 

ÐÅØÅÍÈÅ

ãðàôû – ìèíèìàëüíîå îñòîâíîå äåðåâî

 

Àíàëèç àëãîðèòìà

Èñïîëüçóåì àëãîðèòì Êðóñêàëà äëÿ íàõîæäåíèÿ ìèíèìàëüíîãî îñòîâíîãî äåðåâà.

 

Ðåàëèçàöèÿ àëãîðèòìà

 

#include <cstdio>

#include <vector>

#include <map>

#include <string>

#include <algorithm>

#define MAXV 1010

using namespace std;

 

struct Edge

{

  int u, v;

  double dist;

  Edge(int u = 0, int v = 0, double dist = 0.0) : u(u), v(v), dist(dist) {}

};

 

Edge temp;

vector<Edge> e;

map<string,int> mp;

int mas[MAXV], size[MAXV];

double Len, MST1;

 

void swap(int &x, int &y)

{

  int t = x; x = y; y = t;

}

 

int Repr(int n)

{

  if (n == mas[n]) return n;

  return mas[n] = Repr(mas[n]);

}

 

int Union(int x,int y)

{

  x = Repr(x); y = Repr(y);

  if(x == y) return 0;

  if (size[x] < size[y]) swap(x,y);

  mas[y] = x;

  size[x] += size[y];

  return 1;

}

 

int lt(Edge a, Edge b)

{

  return (a.dist < b.dist);

}

 

int i, j, n, m, tests;

char s[30], s1[30];

 

int main(void)

{

  scanf("%lf",&Len);

  scanf("%d\n",&n);

  for(i = 1; i <= n; i++)

  {

    mas[i] = i; size[i] = 1;

    gets(s);

    mp[(string)s] = i;

  }

 

  scanf("%d\n",&m);

  e.clear();

  for(i = 0; i < m; i++)

  {

    scanf("%s %s %lf\n",s,s1,&temp.dist);

    temp.u = mp[(string)s];

    temp.v = mp[(string)s1];

    e.push_back(temp);

  }

 

  sort(e.begin(),e.end(),lt);

 

  MST1 = 0;

  for(i = 0; i < m; i++)

    if (Union(e[i].u,e[i].v))

      MST1 += e[i].dist;

 

  if (MST1 <= Len)

    printf("Need %.1lf miles of cable\n",MST1);

  else

    printf("Not enough cable\n");

  return 0;

}