2349. Arctic Network

 

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed d, which depends of the power of the transceivers. Higher power yields higher d but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of d is the same for every pair of outposts.

Your job is to determine the minimum d required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

 

Input. The first line of input contains n, the number of test cases. The first line of each test case contains 1 ≤ s ≤ 100, the number of satellite channels, and s < p ≤ 500, the number of outposts. p lines follow, giving the (x, y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

 

Output. For each case, output should consist of a single line giving the minimum d required to connect the network. Output should be specified to 2 decimal points.

 

Sample input

Sample output

1

2 4

0 100

0 300

0 600

150 750

212.13

 

 

РЕШЕНИЕ

графы – алгоритм Прима

 

Анализ алгоритма

Запустим алгоритм Прима. Потроим массив dist, в котором dist[i] хранит длину кратчайшего ребра из минимального остова, входящего в вершину i. То есть как раз из этих ребер и состоит минимальный остов. При этом dist[1] = 0, так как стартуем алгоритм из вершины 1.

По окончанию алгоритма Прима отсортируем массив dist. Спутниковыми каналами следует соединить наиболее отдаленные аванпосты. Их следует разместить в тех s аванпостах, которые соединяют самые длинные ребра из dist (s – 1 ребро соединяет s аванпостов). Следовательно искомым значением d будет длина ребра, являющегося s–ым с конца dist.

 

Реализация алгоритма

 

#include <cstdio>

#include <cmath>

#include <algorithm>

#define MAX 510

#define INF 2100000000

using namespace std;

 

int i, s, n, tests;

int x[MAX], y[MAX];

int used[MAX], dist[MAX];

 

int dist2(int i, int j)

{

  return (x[j] - x[i])*(x[j] - x[i]) + (y[j] - y[i])*(y[j] - y[i]);

}

 

void Prim(void)

{

  memset(dist,0x3F,sizeof(dist));

  memset(used,0,sizeof(used));

 

  int i, j, cur = 1;

  dist[cur] = 0;

  used[cur] = 1;

  for (i = 2; i <= n; i++)

  {

    for (j = 1; j <= n; j++)

      if (!used[j] && (dist2(cur,j) < dist[j]))

        dist[j] = dist2(cur,j);

 

    int min = INF;

    for (j = 1; j <= n; j++)

      if (!used[j] && (dist[j] < min))

      {

        min = dist[j];

        cur = j;

      }

    used[cur] = 1;

  }

}

 

int main(void)

{

  scanf("%d",&tests);

  while(tests--)

  {

    scanf("%d %d",&s,&n);

    for(i = 1; i <= n; i++)

      scanf("%d %d",&x[i], &y[i]);

 

    Prim();

    sort(dist+1,dist+n+1);

    printf("%.2lf\n",sqrt(1.0*dist[n-s+1]));

  }

  return 0;

}