The system of Martians' blood
relations is confusing enough. Actually, Martians bud when they want and where
they want. They gather together in different groups, so that a Martian can have
one parent as well as ten. Nobody will be surprised by a hundred of children.
Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the
confusing genealogical system leads to some embarrassment. There meet the
worthiest of Martians, and therefore in order to offend nobody in all of the
discussions it is used first to give the floor to the old Martians, than to the
younger ones and only than to the most young childless assessors. However, the
maintenance of this order really is not a trivial task. Not always Martian
knows all of his parents (and there's nothing to tell about his grandparents!).
But if by a mistake first speak a grandson and only than his young appearing
great-grandfather, this is a real scandal.
Your task is to write a program, which
would define once and for all, an order that would guarantee that every member
of the Council takes the floor earlier than each of his descendants.
Input. The first
line contains an only number n (1 ≤ n ≤ 100) –
a number of members of the Martian Planetary Council. According to the
centuries-old tradition members of the Council are enumerated with the natural
numbers from 1 up to n. Further, there are exactly n lines,
moreover, the i-th line contains a list of i-th
member's children. The list of children is a sequence of serial numbers of
children in a arbitrary order separated by spaces. The list of children may be
empty. The list (even if it is empty) ends with 0.
Output. The
standard output should contain in its only line a sequence of speakers' numbers,
separated by spaces. If several sequences satisfy the conditions of the
problem, you are to write to the standard output any of them. At least one such
sequence always exists.
Sample input |
Sample output |
5 0 4 5 1 0 1 0 5 3 0 3 0 |
2 4 5 3 1 |
графы – топологическая
сортировка
Анализ алгоритма
В задаче
следует найти любую топологическую сортировку графа, которая всегда существует.
Реализация алгоритма
#include <cstdio>
#include <vector>
using namespace
std;
int a, i, n;
vector<vector<int>
> graph;
vector<int> used, top;
void dfs(int
i)
{
used[i] = 1;
for(int j = 0; j <
graph[i].size(); j++)
{
int to = graph[i][j];
if (!used[to]) dfs(to);
}
top.push_back(i);
}
int main(void)
{
scanf("%d",&n);
graph.resize(n+1);
used.resize(n+1,0);
for(i = 1; i <= n; i++)
{
while(scanf("%d",&a),
a)
graph[i].push_back(a);
}
for(i = 1; i <= n; i++)
if (!used[i]) dfs(i);
for(i = n - 1; i >= 0; i--) printf("%d ",top[i]);
printf("\n");
return 0;
}