7
3
8
8
1 0
2
7 4 4
4
5 2 6 5
Figure shows a number triangle. Write
a program that calculates the highest sum of numbers passed on a route that
starts at the top and ends somewhere on the base. Each step can go either
diagonally down to the left or diagonally down to the right.
Input. Your
program is to read from standard input. The first line contains one integer n: the
number of rows in the triangle. The following n lines
describe the data of the triangle. The number of rows in the triangle is > 1
but ≤ 100. The numbers in the triangle, all integers, are between 0 and
99.
Output. Your
program is to write to standard output. The highest sum is written as an
integer.
Sample input |
Sample output |
0 4 1 1 2 3 2 0 0 2 2 1 1 1 2 1 1 2 -1 2 1 1 2 3 3 |
3 4 |
äèíàìè÷åñêîå
ïðîãðàììèðîâàíèå
Ðåàëèçàöèÿ àëãîðèòìà
#include <stdio.h>
#define MAX 110
int i, j, n, val, mx;
int m[MAX], temp[MAX];
int max(int
i, int j)
{
return (i > j) ? i : j;
}
int main(void)
{
scanf("%d",&n);
scanf("%d",&m[0]);
for(i = 1; i < n; i++)
{
scanf("%d",&val);
temp[0] = m[0] +
val;
for(j = 1; j < i; j++)
{
scanf("%d",&val);
temp[j] =
max(m[j-1],m[j]) + val;
}
scanf("%d",&val);
temp[i] = m[i-1] +
val;
for(j = 0; j <= i; j++)
m[j] = temp[j];
}
mx = m[0];
for(i = 0; i < n; i++)
if (m[i] > mx) mx = m[i];
printf("%d\n",mx);
return 0;
}