As we all know, machine scheduling is
a very classical problem in computer science and has been studied for a very
long history. Scheduling problems differ widely in the nature of the
constraints that must be satisfied and the type of schedule desired. Here we
consider a 2-machine scheduling problem.
There are two machines A and B.
Machine A has n kinds of working
modes, which is called mode_0, mode_1, ..., mode_n-1 , likewise machine B has m
kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.
For k jobs given, each of them can be processed in either one of the
two machines in particular mode. For example, job 0 can either be processed in
machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in
machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a
triple (i, x, y), which means it can
be processed either in machine A at mode_x,
or in machine B at mode_y.
Obviously, to accomplish all the
jobs, we need to change the machine's working mode from time to time, but
unfortunately, the machine's working mode can only be changed by restarting it
manually. By changing the sequence of the jobs and assigning each job to a
suitable machine, please write a program to minimize the times of restarting
machines.
Input. The input
for this program consists of several configurations. The first line of one
configuration contains three positive integers: n, m (n, m
< 100) and k (k < 1000). The following k
lines give the constrains of the k
jobs, each line is a triple: i, x, y.
Output. The
output should be one integer per line, which means the minimal times of
restarting machine.
Sample input |
Sample output |
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0 |
3 |
графы – минимальное покрытие
Построим
двудольный граф: вершинам первой доли поставим в соответствие режимы машины А,
а вершинам второй доли – режимы машины В. Каждой работе (i,
x, y) поставим в соответствие ребро (mode_x,
mode_y). Исключим из графа ребра,
смежные с нулевой вершиной (режимом) как машины А, так и машины В. Поскольку
изначально машины находятся в режимах mode_0, то работы, которые могут быть выполнены в mode_0,
можно совершить не совершив ни одной перезагрузки.
Ищем минимальное
покрытие в двудольном графе. По теореме Кенига оно равно максимальному
паросочетанию.
Реализация алгоритма
#include <cstdio>
#include <vector>
#define MAX 110
using namespace
std;
vector<vector<int>
> g;
vector<int> used, mt,
par;
int i, j, id;
int n, m, k, a, b, flow;
int dfs(int
v)
{
if (used[v]) return
0;
used[v] = 1;
for (int i = 0; i
< g[v].size(); i++)
{
int to = g[v][i];
if (mt[to] == -1 || dfs(mt[to]))
{
mt[to] = v;
par[v] = to;
return 1;
}
}
return 0;
}
void AugmentingPath(void)
{
int i, run;
mt.assign (m+1, -1);
par.assign (n+1, -1);
flow = 0;
for (run = 1; run; )
{
run = 0;
used.assign(n+1, 0);
for (i = 1; i < n; i++)
if ((par[i] == -1) && dfs(i))
{
flow++;
run = 1;
}
}
}
int main(void)
{
while(scanf("%d %d
%d",&n,&m,&k) == 3)
{
g.assign(n+1,vector<int>());
for(i = 0; i < k; i++)
{
scanf("%d %d %d",&id,&a,&b);
if ((a != 0) && (b != 0))
g[a].push_back(b);
}
AugmentingPath();
printf("%d\n",flow);
}
return 0;
}