The island nation of Flatopia is
perfectly flat. Unfortunately, Flatopia has a very poor system of public
highways. The Flatopian government is aware of this problem and has already
constructed a number of highways connecting some of the most important towns.
However, there are still some towns that you can't reach via a highway. It is
necessary to build more highways so that it will be possible to drive between
any pair of towns without leaving the highway system.
Flatopian towns are numbered from 1
to n and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All
highways (both the original ones and the ones that are to be built) follow
straight lines, and thus their length is equal to Cartesian distance between
towns. All highways can be used in both directions. Highways can freely cross
each other, but a driver can only switch between highways at a town that is
located at the end of both highways.
The Flatopian government wants to minimize
the cost of building new highways. However, they want to guarantee that every
town is highway-reachable from every other town. Since Flatopia is so flat, the
cost of a highway is always proportional to its length. Thus, the least
expensive highway system will be the one that minimizes the total highways
length.
Input. The input
consists of two parts. The first part describes all towns in the country, and
the second part describes all of the highways that have already been built.
The first
line of the input contains a single integer n (1 ≤ n ≤
750), representing the number of towns. The next n lines each
contain two integers, xi
and yi separated by a
space. These values give the coordinates of i-th town (for i
from 1 to n).
Coordinates will have an absolute value no greater than 10000. Every town has a
unique location.
The next
line contains a single integer m (0 ≤ m ≤ 1000), representing the number of existing
highways. The next m lines each contain a pair of integers separated by a
space. These two integers give a pair of town numbers which are already
connected by a highway. Each pair of towns is connected by at most one highway.
Output. Write to
the output a single line for each new highway that should be built in order to
connect all towns with minimal possible total length of new highways. Each
highway should be presented by printing town numbers that this highway
connects, separated by a space.
If no new
highways need to be built (all towns are already connected), then the output
file should be created but it should be empty.
Sample input |
Sample output |
9 1 5 0 0 3 2 4 5 5 1 0 4 5 2 1 2 5 3 3 1 3 9 7 1 2 |
1 6 3 7 4 9 5 7 8 3 |
графы – минимальный остов –
алгоритм Прима
Выделим
компоненты связности по уже имеющимся связям, воспользовавшись системой
непересекающихся множеств. Запустим алгоритм Прима. Если релаксируется ребро,
соединяющее вершины из одной компоненты связности, считаем его длину равной
нулю. При добавлении ребра в минимальный остов объединяем в одно множество
вершины на его концах.
Реализация алгоритма
#include <cstdio>
#include <vector>
#include <algorithm>
#define MAXV 755
using namespace
std;
int mas[MAXV], size[MAXV], res;
int i, j, to, n, m, u, v;
int x[MAXV], y[MAXV];
int used[MAXV], min_e[MAXV],
end_e[MAXV];
void swap(int
&x, int &y)
{
int t = x; x = y; y = t;
}
int Repr(int
n)
{
if (n == mas[n]) return
n;
return mas[n] = Repr(mas[n]);
}
int Union(int
x,int y)
{
x = Repr(x); y =
Repr(y);
if(x == y) return 0;
if (size[x] < size[y]) swap(x,y);
mas[y] = x;
size[x] += size[y];
return 1;
}
int dist2(int
i, int j)
{
return (x[j] - x[i])*(x[j] - x[i]) + (y[j] -
y[i])*(y[j] - y[i]);
}
int main(void)
{
scanf("%d",&n);
for(i = 1; i <= n; i++)
scanf("%d %d",&x[i], &y[i]);
for(i = 1; i <= n; i++)
mas[i] = i, size[i]
= 1;
scanf("%d",&m);
for(i = 0; i < m; i++)
{
scanf("%d %d",&u,&v);
Union(u,v);
}
memset(min_e,0x3F,sizeof(min_e));
memset(end_e,-1,sizeof(end_e));
memset(used,0,sizeof(used));
min_e[1] = 0;
for (i = 1; i <= n; i++)
{
v = -1;
for (j = 1; j <= n; j++)
if (!used[j] && (v == -1 || min_e[j] <
min_e[v])) v = j;
used[v] = 1;
if ((end_e[v] != -1) && (Repr(end_e[v]) !=
Repr(v)))
{
printf("%d %d\n",end_e[v],v);
Union(end_e[v],v);
}
for (to = 1; to <= n; to++)
{
int dV_TO = dist2(v,to);
if (Repr(v) == Repr(to)) dV_TO = 0;
if (!used[to] && (dV_TO < min_e[to]))
{
min_e[to] =
dV_TO;
end_e[to] = v;
}
}
}
return 0;
}