7259. Light Switching

 

Farmer John tries to keep the cows sharp by letting them play with intellectual toys. One of the larger toys is the lights in the barn. Each of the n (2 ≤ n ≤ 100,000) cow stalls conveniently numbered from 1 to n has a colorful light above it.

At the beginning of the evening, all the lights are off. The cows control the lights with a set of n pushbutton switches that toggle the lights; pushing switch i changes the state of light i from off to on or from on to off.

The cows read and execute a list of m (1 ≤ m ≤ 100,000) operations expressed as one of two integers (0 ≤ operation ≤ 1).

The first kind of operation (denoted by a 0 command) includes two subsequent integers Si and Ei (1 ≤ SiEin) that indicate a starting switch and ending switch. They execute the operation by pushing each pushbutton from Si through Ei inclusive exactly once.

The second kind of operation (denoted by a 1 command) asks the cows to count how many lights are on in the range given by two integers Si and Ei (1 ≤ SiEin) which specify the inclusive range in which the cows should count the number of lights that are on.

Help Farmer John ensure the cows are getting the correct answer by processing the list and producing the proper counts.

 

Input. The first line contains two space-separated integers n and m. Each of the next m lines represents an operation with three space-separated integers: operation, Si and Ei.

 

Output. For each operation of the second kind print the answer as an integer on a single line.

 

Sample input

4 5

0 1 2

0 2 4

1 2 3

0 2 4

1 1 4

 

Sample output

1

2

 

 

РЕШЕНИЕ

структуры данныхдерево отрезков

 

Анализ алгоритма

Для решения задачи следует реализовать дерево отрезков, поддерживающее групповую модификацию – операцию исключающего ИЛИ (XOR) и суммирование.

В каждом узле дерева будут поддерживаться значения двух переменных: суммы на отрезке summa и некоторого дополнительного значения add. Равенство add единице означает, что значения всех элементов соответствующего отрезка следует изменить на противоположное.

Протолкнуть значение add по дереву на один уровень ниже означает пересчитать значения summa левого и правого поддерева, а также изменить значения add левого и правого поддерева на противоположное (0 на 1, или 1 на 0), тем самым рекурсивно обеспечив проталкивание значения add до листьев дерева.

Операцию проталкивания следует производить не только при выполнении операции прибавления на отрезке, но и при вычислении сумм.

Пусть отрезок [a; b] соответствует некоторой вершине дерева, и значения всех его элементов  следует изменить на противоположное. Тогда количество включенных лампочек summa станет равно числу выключенных до этого лампочек ba + 1 – summa.

 

Реализация алгоритма

 

#include <cstdio>

#include <algorithm>

#define MAX 100100

using namespace std;

 

struct node

{

  int summa, add;

} SegTree[4*MAX];

 

int mas[MAX];

 

void build (int *a, int Vertex, int LeftPos, int RightPos)

{

  if (LeftPos == RightPos)

  {

    SegTree[Vertex].summa = a[LeftPos];

    SegTree[Vertex].add = 0;

  }

  else

  {

    int Middle = (LeftPos + RightPos) / 2;

    build (a, 2*Vertex, LeftPos, Middle);

    build (a, 2*Vertex, Middle+1, RightPos);

 

    SegTree[Vertex].summa =

      SegTree[2*Vertex].summa + SegTree[2*Vertex+1].summa;

    SegTree[Vertex].add = 0;

  }

}

 

void Push(int Vertex, int LeftPos, int Middle, int RightPos)

{

  if (SegTree[Vertex].add)

  {

    SegTree[2*Vertex].add ^= SegTree[Vertex].add;

    SegTree[2*Vertex].summa =

      (Middle - LeftPos + 1) - SegTree[2*Vertex].summa;

    SegTree[2*Vertex+1].add ^= SegTree[Vertex].add;

    SegTree[2*Vertex+1].summa =

      (RightPos - Middle) - SegTree[2*Vertex+1].summa;

    SegTree[Vertex].add = 0;

  }

}

 

void SetValue(int Vertex, int LeftPos, int RightPos, int Left, int Right)

{

  if (Left < LeftPos)  Left = LeftPos;

  if (Right > RightPos) Right = RightPos;

  if (Left > Right) return;

 

  if ((LeftPos == Left) && (RightPos == Right))

  {

    SegTree[Vertex].add = 1 - SegTree[Vertex].add;

    SegTree[Vertex].summa = (Right - Left + 1) - SegTree[Vertex].summa;

    return;

  }

 

  int Middle = (LeftPos + RightPos) / 2;

  Push(Vertex,LeftPos,Middle,RightPos);

 

  SetValue(2*Vertex, LeftPos, Middle, Left, Right);

  SetValue(2*Vertex+1, Middle+1, RightPos, Left, Right);

 

  SegTree[Vertex].summa = SegTree[2*Vertex].summa + SegTree[2*Vertex+1].summa;

}

 

int Summa(int Vertex, int LeftPos, int RightPos, int Left, int Right)

{

  if (Left < LeftPos)  Left = LeftPos;

  if (Right > RightPos) Right = RightPos;

  if (Left > Right) return 0;

 

  if ((LeftPos == Left) && (RightPos == Right)) return SegTree[Vertex].summa;

 

  int Middle = (LeftPos + RightPos) / 2;

  Push(Vertex,LeftPos,Middle,RightPos);

 

  return Summa(2*Vertex, LeftPos, Middle, Left, Right) +

         Summa(2*Vertex+1, Middle+1, RightPos, Left, Right);

}

 

int i, L, R, type, pos, Value, n, m;

struct node res;

 

int main(void)

{

  scanf("%d %d",&n,&m);

  build(mas,1,0,n-1);

 

  for(i = 0; i < m; i++)

  {

    scanf("%d %d %d",&type,&L,&R);

    if (type)

      printf("%d\n",Summa(1,0,n-1,L-1,R-1));

    else

      SetValue(1,0,n-1,L-1,R-1);

  }

  return 0;

}