11151. Longest Palindrome

 

A palindrome is a string that reads the same from the left as it does from the right. For example, I, GAG and MADAM are palindromes, but ADAM is not. Here, we consider also the empty string as a palindrome.

From any non-palindromic string, you can always take away some letters, and get a palindromic subsequence. For example, given the string ADAM, you remove the letter M and get a palindrome ADA.

Write a program to determine the length of the longest palindrome you can get from a string.

 

Input. The first line contains an integer t (≤ 60). Each of the next t lines is a string, whose length is always less than 1000.

 

Output. For each input string, your program should print the length of the longest palindrome you can get by removing zero or more characters from it.

 

Sample Input

2

ADAM

MADAM

 

Sample Output

3

5

 

 

РЕШЕНИЕ

динамическое программирование

 

Анализ алгоритма

Наибольшая общая подпоследовательность строки и ее реверса является наибольшим палиндромом, который можно получить из строки удалением букв.

 

Рассмотрим второй вариант решения задачи. Пусть Solve(i, j) возвращает длину максимального палиндрома, который можно получить из строки sisj удалением букв. Тогда

·         если si = sj, то Solve(i, j) = 2 + Solve(i + 1, j – 1);

·         если si не входит в максимвльный палиндром, то Solve(i, j) = Solve(i + 1, j);

·         если sj не входит в максимвльный палиндром, то Solve(i, j) = Solve(i, j – 1);

Остается при si ≠ sj в качестве Solve(i, j) выбрать max(Solve(i + 1, j), Solve(i, j – 1)).

Положим также:

·         Solve(i, i) = 1, так как слово из одной буквы является палиндромом;

·         Solve(i, i + 1) = 1 при si ≠ si+1 и Solve(i, i + 1) = 2 при si = si+1.

 

Реализация алгоритма – через наибольшую общую подпоследовательность

 

#include <cstdio>

#include <algorithm>

#include <cstring>

#define MAX 1010

 

using namespace std;

 

char x[MAX], y[MAX], res[MAX];

int m[MAX][MAX];

int tests, i, j, len, ptr = 0;

 

int main(void)

{

  scanf("%d",&tests);

  getc(stdin);

  while(tests--)

  {

    x[0] = y[0] = 0;

    gets(x+1); len = strlen(x+1);

    strcpy(y+1,x+1);

    reverse(y+1,y+1+len);

 

    memset(m,0,sizeof(m));

    for(i = 1; i <= len; i++)

    for(j = 1; j <= len; j++)

      if (x[i] == y[j]) m[i][j] = 1 + m[i-1][j-1];

      else m[i][j] = max(m[i-1][j],m[i][j-1]);

 

    printf("%d\n",m[len][len]);

  }

  return 0;

}

 

Реализация алгоритма – динамическое программирование

 

#include <cstdio>

#include <algorithm>

#include <cstring>

#define MAX 1010

 

using namespace std;

 

char s[MAX];

int dp[MAX][MAX];

int tests, len, i, j;

 

int Solve(int i, int j)

{

  if (i == j) return 1;

  if (i + 1 == j) return (s[i] == s[j]) + 1;

  if (dp[i][j] != -1) return dp[i][j];

 

  if (s[i] == s[j])

    return dp[i][j] = 2 + Solve(i+1,j-1);

  else

    return dp[i][j] = max(Solve(i,j-1), Solve(i+1,j));

}

 

int main(void)

{

  scanf("%d",&tests);

  getc(stdin);

  while(tests--)

  {

    gets(s); len = strlen(s);

    if(len == 0)

    {

      printf("0\n");

      continue;

    }

 

    memset(dp,-1,sizeof(dp));

    printf("%d\n",Solve(0,len-1));

  }

  return 0;

}